Config files not correct after a 'red bar' update

5 posts / 0 new
Last post
linker3000
linker3000's picture
Config files not correct after a 'red bar' update

Hi,

Hi, Currently on FreePBX 2.2.0rc3 with Trixbox 2.2. I have two wonderfully working systems and one that has a minor issue - as soon as I click the red bar following any update or change, my SIP trunk will not register with the service provider and I have tracked this down to sip_additional.conf - every time it's re-created, the 'register' line is missing - eg:

BEFORE:
; do not edit this file, this is an auto-generated file by freepbx
; all modifications must be done from the web gui
register=XXXXX:YYYYY@registrar.voip.co.uk/XXXXX

[XXXXX]
type=user
secret=YYYYY
insecure=very
host=proxy.voip.co.uk
fromuser=XXXXX
context=from-trunk

AFTER:
; do not edit this file, this is an auto-generated file by freepbx
; all modifications must be done from the web gui

[XXXXX]
type=user
secret=YYYYYY
insecure=very
host=proxy.voip.co.uk
fromuser=XXXXX
context=from-trunk

So, at the moment, if I make an changes I have to manually put the register line back in and issue an 'amportal restart'.

Is this a known problem? While trying to fix this, I have updated Asterisk from SVN so have posted a question elsewhere to make sure it's OK to update to FreePBX 2.2.2 with this. Having said that, my other two systems were working fine with FreepBX 2.2.0rc3 (but have since been upgraded) so I am a bit puzzled.

Any thoughts or info appreciated.

Thanks

p_lindheimer
p_lindheimer's picture
Config files not correct after a 'red bar' update

upgrade to a supported release like 2.2.2 and then see if you still have your issue.

linker3000
linker3000's picture
Config files not correct after a 'red bar' update

p_lindheimer wrote:

upgrade to a supported release like 2.2.2 and then see if you still have your issue.

Hi,

Just put on 2.2.2 - still doing the same thing.

p_lindheimer
p_lindheimer's picture
Config files not correct after a 'red bar' update

in 2.2.2 it will now put the sip registrations in sip_registrations.conf so take a look there to see if anything is getting written. If not, see if there is any helpful information in /var/log/asterisk/freepbx-retieve.log.

linker3000
linker3000's picture
Config files not correct after a 'red bar' update

p_lindheimer wrote:

in 2.2.2 it will now put the sip registrations in sip_registrations.conf so take a look there to see if anything is getting written. If not, see if there is any helpful information in /var/log/asterisk/freepbx-retieve.log.

You're right - the registration string is in sip_registrations.conf, but no trunk registration is maintained until I add the line back to sip_additional.conf.

OK - I have added a line to sip.conf so the end is like below - this works! Possibly caused by copying a 'working' sip.conf from an older installation.

; #, in this configuration file, is NOT A COMMENT. This is exactly
; how it should be.
#include sip_nat.conf
#include sip_custom.conf
#include sip_registrations.conf
#include sip_additional.conf

Thanks for the input.