Upgrades Past 1.87.29.55-2

17 posts / 0 new
Last post
darrylmc
darrylmc's picture
Upgrades Past 1.87.29.55-2

Is there the possibility to continue asterisk/dahdi/wanpipe upgrades on the 2.9 distro platform?

I'm specifically asking because of a PRI "resource unavailable" problem I am experiencing (most likely the one reported in ASTERISK-18405) with 1.8.7.1.

I know the developers can't be expected to maintain multiple versions of their software until the end of time, but perhaps a script could be made to help with the upgrade to asterisk 1.8.10, dahdi 2.6 and wanpipe 3.5.24+ which would match the latest v2.10 release (but without the distro upgrade).

tonyclewis
tonyclewis's picture
You would be on your own for

You would be on your own for this. We just do not have the resources to maintain old releases. Is their a specific reason you do not want to upgrade to the latest Distro Version?

This is why we provide upgrades scripts to the latest version. The way our yum repos are designed and setup each main version has its own repo so this would take adding all these packages to older versions. The main issue is the old2.9 is on Centos 5.5 so we would have to compile new dahdi and wanpipe for your kernel when we are only building those for the 5.7 Centos kernel.

Tony Lewis
Schmooze Com/FreePBX
Opening a Bug or Feature request demo video

darrylmc
darrylmc's picture
GUI!

The main reason we haven't upgraded yet is the changes to the GUI. It's just unfortunate because we have a lot of stable 1.87.29.55-2 PBXs deployed, and it wasn't until today when one with a PRI on it went from 1.8.2.0-2 -> 1.87.29.55-2 did this bug become an issue (if it does match the bug I mentioned which was a regression in asterisk 1.8.7).

Is it relatively safe (although not supported understandbly) to compile from source ourselves the asterisk/dahdi/libpri & wanrouter packages while maintaining the FreePBX distro version where it is?

tonyclewis
tonyclewis's picture
Sure you could do that but

Sure you could do that but you would never be able to use the upgrade scripts in the future as you would have lots of problems when the scripts try to upgrade RPM's and it kind of defeats the purpose of using a Distro like FreePBX

Tony Lewis
Schmooze Com/FreePBX
Opening a Bug or Feature request demo video

darrylmc
darrylmc's picture
Agreed

I agree, the distro is a lifesaver really, as I did use to do all that manually.
I should have mentioned too that some customizations we made to the dial plan were another reason not to upgrade at this time, not just the GUI. It just means we need to take some time and go through it properly to fully understand the changes, fixes & new features before going on a production box. This is the least we can do of course, as yours and all developers/contributors time is appreciated for what we have.

So if I manually update these packages, upgrades later using the scripts WILL fail?

darrylmc
darrylmc's picture
Upgraded on a test machine...

I upgraded on a test machine from 1.87.29.55-2 thru -> 1.810.210.57-1. Maybe I missed something, or misunderstood, but asterisk, dahdi, wanpipe, centos all updated like they should, but the modules are still v2.9, with the option of the 2.10 upgrade module to be installed. Is this expected? If so, it would seem I could carry on with upgrades and not be forced into the 2.10 GUI right away.

There is 2 issues though so far:

When trying to install System Admin:
Module Administration

Errors with selection:

System Admin cannot be installed:
PHP Component Zend Optimizer is required but missing from you PHP installation.
Please try again after the dependencies have been installed.

When checking with yum, I get this:
[root@localhost ~]# yum install *zend*
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Install Process
Package php-5.3-zend-guard-loader-5.5.0-3.i686 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package php-5.3-zend-guard-loader-debuginfo.i686 0:5.5.0-3 set to be updated
---> Package zend-optimizer.i386 0:3.3.3-3 set to be updated
--> Processing Dependency: php < 5.3 for package: zend-optimizer
--> Finished Dependency Resolution
zend-optimizer-3.3.3-3.i386 from pbx has depsolving problems
--> Missing Dependency: php < 5.3 is needed by package zend-optimizer-3.3.3-3.i386 (pbx)
Error: Missing Dependency: php < 5.3 is needed by package zend-optimizer-3.3.3-3.i386 (pbx)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

And secondly, module 'dahdi config' is broken, and won't install:
Please wait while module actions are performed

Error(s) installing dahdiconfig:
Cannot find module

I've never had an issue with the dahdi config module (for sangoma PRI card) so would like to continue using it.

Any thoughts/suggestions would be appreciated!

darrylmc
darrylmc's picture
Dahdi module resolved

I did resolve the dahdi module problem, by uninstalling/installing the module, then moving the chan_dahdi.conf file so that the symlink could be created properly on reload (as I read on another post).

There is still a PHP 5.3 issue with installing System Admin though, so any help would still be appreciated.

darrylmc
darrylmc's picture
Zend Optimizer install problem

Is there a mistake in the repo that the wrong zend optimizer is trying to install? I'm running 1.810.210.57-1 and show PHP 5.3 is installed, but:

Installed Packages
php-5.3-zend-guard-loader.i686 5.5.0-3 installed
Available Packages
php-5.3-zend-guard-loader-debuginfo.i686 5.5.0-3 pbx
zend-optimizer.i386 3.3.3-3 pbx

zend-optimizer-3.3.3-3.i386 from pbx has depsolving problems
--> Missing Dependency: php < 5.3 is needed by package zend-optimizer-3.3.3-3.i386 (pbx)
Error: Missing Dependency: php < 5.3 is needed by package zend-optimizer-3.3.3-3.i386 (pbx)

tonyclewis
tonyclewis's picture
do a yum clean all

do a yum clean all first.

zend-optimizer is for less than php 5.3.

Tony Lewis
Schmooze Com/FreePBX
Opening a Bug or Feature request demo video

darrylmc
darrylmc's picture
I did as suggested

Hi, thanks for the reply, I did as suggested, but I think what you're saying is zend-optimizer is not needed since php 5.3 is isntalled. If that is the case, can you assist with this error when trying to install the System Admin module:

System Admin cannot be installed:
PHP Component Zend Optimizer is required but missing from you PHP installation.
Please try again after the dependencies have been installed.

tonyclewis
tonyclewis's picture
Are you using FreePBX 2.9 or

Are you using FreePBX 2.9 or 2.10. If you used the upgrade scripts you should be on 2.10 as 2.10 modules are built for php 5.3. The 2.9 commercial modules will not work on php 5.3

Tony Lewis
Schmooze Com/FreePBX
Opening a Bug or Feature request demo video

darrylmc
darrylmc's picture
2.9

I DID use the upgrade scripts, and was surprised as well that I wasn't forced to 2.10. Somewhere in the beginning of this thread, I did wonder/ask if something was wrong, since I still have all the 2.9 modules running, but I do see the 2.10 upgrade tool as being available.

So, yes, I can run the upgrade tool if that is required, but so far, only system admin is having an issue, and nothing happened automatically.
(I upgraded sequentially from 1.87.29.55-2)

tonyclewis
tonyclewis's picture
Yes update all your modules

Yes update all your modules to 2.10 using the upgrade module

Tony Lewis
Schmooze Com/FreePBX
Opening a Bug or Feature request demo video

darrylmc
darrylmc's picture
updated to 2.10

Ok, I took the plunge, and upgraded to 2.10. I still can't install System Admin oddly enough:

Please wait while module actions are performed

Error(s) installing sysadmin:
PHP Component Zend Optimizer is required but missing from you PHP installation.

Return

maple
maple's picture
I also want to stay at 2.9 but upgrade Asterisk

My primary reason for wanting to stay at 2.9 is the fear that some third-party modules that I rely on, particularly the Swiss Army Knife module, will stop working.

But, I do want to upgrade Asterisk to the latest version in the 1.8 branch. I understand from the above discussion that I will no longer be able to use the distro upgrades, but I can live with that if I have to. My only question is, does the FreePBX distro apply any patches to the Asterisk source code that is available from Digium's site, and if so, it there a way to get the patched version of Asterisk or the patches from your site without doing a full distro upgrade?

Currently I am at distro version 1.87.29.55-2

maple
maple's picture
Anyone home?

Can't anyone tell me whether the FreePBX Distro patches Asterisk in any way when installing a new version?

tonyclewis
tonyclewis's picture
Yes we have a few patches

Yes we have a few patches for some things with CCSS and such

Tony Lewis
Schmooze Com/FreePBX
Opening a Bug or Feature request demo video