bad destination - parking lot

12 posts / 0 new
Last post
rpyne
rpyne's picture
bad destination - parking lot

I am new to FreePBX and am running version 2.9.0.1. Since enabling call parking, I am getting a notice:

There are 1 bad destinations
DEST STATUS: EMPTY
Parking Lot

Call parking appears to be working, so I am wondering what is wrong.

Thanks for any help.

asterisk21st
asterisk21st's picture
mine says the same thing so

mine says the same thing so I just ignore it. Wink

VoIPTek
VoIPTek's picture
BUMP

Anybody have an answer on this?

alan_mousty
alan_mousty's picture
I think this is a bug.

I think this is a bug. I just ignore it.

peterbokunet
peterbokunet's picture
Parking Lot

Chances are you're seeing this because you enabled the Parking Lot module but not intending to use it. Disable the module in Module Admin and the message goes away.

--
Take the sardonic comments with a grain of salt.
(The rest is meant in earnest.)

alan_mousty
alan_mousty's picture
I have parking enabled and I

I have parking enabled and I use the feature and still get this message. I still think it is a bug.

VoIPTek
VoIPTek's picture
???

That doesn't make sense. The module is enabled so that it can be used, the message is either a BUG or, there is some setting that is omitted from the default install that it's expecting. I have this in multiple servers and we are using the feature.

Dean.Collins
Dean.Collins's picture
did you tick the box

lol for whatever reason i didnt' see that you had to "tick the box" above the extension number you assign for parking which says "Enable Parking Lot Feature"

i never got around to testing parking lot feature as never use it but i did have to change the extension number and unless you tick this box you well get an error message it makes total sense...but yeh i wish the UI made more sense..

VoIPTek
VoIPTek's picture
Yes

Hi Dean,

Yes, that checkbox is on. I believe the parking lot won't work without it and the parking lot does work, I believe its an a bug in the message more so than it not working. After upgrading to the 2.10x branch I have seen that go away.

Thanks!

p_lindheimer
p_lindheimer's picture
Sounds like you have not set

Sounds like you have not set the Alternate Destination Behavior.

If that's the case, to the extent it's a bug, I guess we should probably set it to some default. Problem with that, what default? Better to remind you in such a message so you see you missed something.

I guess we should also complain if we are not when you don't choose a destination?

Anyhow … check that and for the other people's sake who chimed in you may want to let them know if that was the case.

VoIPTek
VoIPTek's picture
Alternate is set to the Originator

I believe that's the default and what I want anyway as to how it should behave.
FYI you have to pick one or the other, it won't stay blank.

TreadingWater
TreadingWater's picture
"== choose one ==" Must Be Changed

Whether or not you set "Return Destination Behavior" to Originator or Alternate Destination, you still have to change the drop down to something other than "== choose one ==" if you are going to enable the parking lot feature. This will remove the bad destination error. Yes, logic would dictate that this should only need to be changed IF Alternate Destination is chosen (ie enabled/activated). But.....for the sake of sanity, this should fix it for now. Smile