IVR not playing message

7 posts / 0 new
Last post
jbone902
jbone902's picture
IVR not playing message

I installed the IVR module i uploaded a few wav file that are 8000khz and 16 bit. I then set the IVR to play them, when i call all i hear is blank sound and after i time it it calls the extension like it should. How do i get the message to play i have tried change its directory to /var/lib/asterisk/sounds/en/ and it still does nothing, i aslo tried converting the file to .gsm, .mp3, .ualw, and .wav and nothing works. Please help

jbone902
jbone902's picture
oh, Im running freepbx

oh, Im running freepbx 2.10.1.1 and asterisk 1.8 on unbuntu server 12.04

p_lindheimer
p_lindheimer's picture
I would suggest you first

I would suggest you first grab a system recording that you know works for your IVR to do a sanity check. If that plays, but your's does not, then you can be fairly certain that it's likely a formatting issue.

You can check the CLI when calling the IVR to do a sanity check that you see it think's it's attempting to play it. You can also check the logs to see if there are any errors logged when attempting to play it.

jbone902
jbone902's picture
how would i check in the

how would i check in the CLI, and yes the built-in recordings EX: demo-instruct work. I'm very new to freePBX and Linux so i may be slow on things. Upon evalutaing the log files the only warning/error i found were:
[2012-07-11 12:31:16] WARNING[17902] file.c: File custom/hellowav does not exist in any format
[2012-07-11 12:31:16] WARNING[17902] file.c: Unable to open custom/hellowav (format 0x4 (ulaw)): No such file or directory
[2012-07-11 12:31:16] WARNING[17902] pbx.c: ast_streamfile failed on SIP/fpbx-2-bfc230c6-000000f6 for custom/hellowav

What would i do about these?

p_lindheimer
p_lindheimer's picture
for some reason it is not

for some reason it is not finding your file.

You can check to see if it got loaded properly. Since you hand installed FreePBX there may be issues with your asterisk.conf setup though FreePBX should use what is in there.

Normally the custom sound files you load are installed in:

/var/lib/asterisk/sounds/custom/

you may want to check if this is set under options section of asterisk.conf:

languageprefix=yes

I completely forget now if that is related with how we do things in FreePBX but might be.

jbone902
jbone902's picture
For some reason, the Ubuntu

For some reason, the Ubuntu build of asterisk uses /usr/share/asterisk as its data dir (this is configured as astdatadir in /etc/asterisk/asterisk.conf). If I change that, we break a bunch of things, so what I did was I remapped a symlink (/usr/share/asterisk/sounds/custom) to /var/lib/asterisk/sounds/custom.

thanks for the help, I was a little lost because i'm just an intern and i was given this huge task.

p_lindheimer
p_lindheimer's picture
glad you fixed it. If you

glad you fixed it.

If you are fairly new to all this, you may wan to consider simply reloading FreePBX from the fully configured Distro. It's not Ubuntu so that could be a problem if you have that as a real requirement. On the flip side, if that is just preferred, you'll probably save yourself a lot of future headaches since the Distro pretty much makes everything 'just work."