Registering Patton SmartNode with FreePBX

6 posts / 0 new
Last post
ozeeo
ozeeo's picture
Registering Patton SmartNode with FreePBX

hello all,

I am trying to configure my newly purchased Patton SN4114/JO with my FreePBX server. I have managed to do the basic configuration on the Patton to talk with my PBX (please see my Patton running config).

So right now when an incoming call is placed on the telephone line, the call is detected by Patton and passed to PBX, which rings on my telephone (line > Patton > PBX > IP TEL). However i am not able to place calls from my PBX using the Patton (IP Tel > PBX > Patton > line). i have obviously defined a Trunk and Outbound route for this.

As I can not place a call from my PBX through Patton, i am assuming that this is because Patton is failing to register with PBX (see image).
i have tried to add some users under SIP > Authentication Services (please see attached patton running config) and Location Services, the same data has been added in PBX under the Trunk peer details (please see asterisk trunk config). With my limited understanding of Patton i am not sure if the problem is with the Patton configuration or Asterisk. I have not managed to find any trunk setting that works with the Patton gateway. I have played around with the setting and had no luck with any combination.

I would appreciate if you could provide me with working settings for FreePBX/Asterisk trunk that would allow Patton to register! or is there a problem with my Patton config. Please advise.

here are my system info:

Patton SN4114/JO/EUI
Hardware version: 4.4
Software v.: R6.1 2012-05-09 H323 SIP FXS FXO
IP 192.168.3.244

FreePBX 2.8.1.5
Trunk Setting
Trunk Name: Patton4114
username=patton
type=friend
insecure=very
host=192.168.3.244
dtmfmode=RFC2833
disallow=all
context=from-trunk
canreinvite=no
allow=alaw&g729

Patton Running Config
http://www.2shared.com/document/5c_EuhN0/runningcfg.html

Patton Registration Status
http://www.2shared.com/photo/2ALu6Geo/PattonRegStatus.html

Patton Gateway
http://www.2shared.com/photo/NVVUEdl3/Patton_Gateway.html

Patton Location Services
http://www.2shared.com/photo/1Go5lRDY/PattonLocationServ.html

Patton Authentication Services
http://www.2shared.com/photo/PaPVZrBC/PattonAuthen.html

crewnecktech
crewnecktech's picture
Hi ozeeo,

Hi ozeeo,

I just jumped into the same boat with a new Patton SN4114. I wondered if you were able to get everything up and running? If so could you let me know what you ended up with that worked?

Thanks for any help you could provide!

ozeeo
ozeeo's picture
Hi crewnecktech,

Hi crewnecktech,
yes i did indeed fix the problem! i dont know if your setup is the same as mine but i could post my configs if you want.
can you also tell me what are you having problem with? is it registration or call routing or some setting with the patton box itself?

pigsfoot
pigsfoot's picture
Patton Config Posted

Hi,

I just posted my working Patton 4120 config on the forum, just search for Patton 4120 config and I'm sure you will find it.

Thanks

crewnecktech
crewnecktech's picture
Thanks!

pigsfoot - Thanks for the config file, I'll reference it, but I'm not sure how close it is to what I need as I'm using 4 FXO ports rather than ISDN stuff.

crewnecktech
crewnecktech's picture
Thanks!

Ozeeo - I'm hoping to be able to recognize a call as originating from any of the 4 lines and have freepbx route it as a "DID" for that line, and also pass along CID. I'm also hoping to be able to use the lines for outgoing routing too (if ext 1 dials out use this line, but otherwise use one of the other 3). Right now, I've got incoming working, but I can't tell which line they dialed in on and callerID is always "anonymous" even though the phone I'm calling from normally sends callerID with a number. I also have outgoing working, but it always goes out on line 1. Any help you could give would be much appreciated!