Could not reload FOP server - message

36 posts / 0 new
Last post
chucknb28409
chucknb28409's picture
Could not reload FOP server - message

Hi,

I am getting this "Could not reload FOP server" message with the following details - Could not reload the FOP operator panel server using the bounce_op.sh script. Configuration changes may not be reflected in the panel display.
Added 1 hour, 5 minutes ago
(freepbx.reload_fop)

I looked at the ticket for closed bugs #2217 and this did not fix the issue. Any other ideas?

Thanks

Chuck Bunn

thunderheart
thunderheart's picture
Same here

Chuck,

I'm having the same issue and like you, I looked at the closed bug but the solution didn't apply. I installed in a bit of a round about way so I imagine my problem is a configuration issue associated with that process.

I started with a VERY basic Centos 5 install. Got the * and FreePBX sources from the EASYVOXBOX distro. Then edited their install script to ignore the stuff specific to EVB. There were a couple of minor hiccups but got everything working except FOP. The warning message I get is basically "can't reload FOP server with bounce_op.sh". Funny thing is I can logon to the machine as root and start the server. The status will then show green but I still can't access the panel. If you come up with a solution, please share it here and if anyone else has a suggestion then I am ALL ears (well eyes really).

Thunderheart

chucknb28409
chucknb28409's picture
Could not reload FOP server - message

I have everything working including FOP, I just get this message in the system status window. So I assume its a bogus message, it just annoying to have it keep poping up.

Thanks

asarkar
asarkar's picture
Could not load FOP Server

please change manage_user : and manage_secret : of /var/www/html/panel/op_server.cfg to asterisks /etc/asterisk/manager.conf admin and secret. Then RESTART the machine which reload op_server.pl on port 4445

LCannon
LCannon's picture
"Could not load FOP Server"

Could you clearify your message a bit more? I'm in the file "op_server.cfg" and see:

; user and secret connting to * manager
manager_user=UNUSED
manager_secret=UNUSED

Are you saying to change the "UNUSED" to "asterisks /etc/asterisk/manager.conf"?

???

Please pardon my need for detail. I'm rather new to this.

compused
compused's picture
FOP server

Hi
I got FOP running without error messages by renaming the bounce_op.sh file in:
/var/www/html/admin/bounce_op.sh

to eg
/var/www/html/admin/bounce_op.sh_old

then restarting asterisk

Michael Daly
Melbourne
Australia

Michael Daly
Melbourne
Australia

jperry999
jperry999's picture
Also see here
taijitutech
taijitutech's picture
FOP unalbe to load message

I did some checking and when looking into the amportal.conf file the AMPWEBADDRESS value was being set to AMPWEBADDRESS=xx.xx.xx.xx and I after looking at another system that worked there was no xx.xx.xx.xx. it was only AMPWEBADDRESS=
so after removing the xx.xx.xx.xx
The server was able to resolve the IP to the localhost and everything worked.

pctouch
pctouch's picture
I did checked for both on a fresh installation and still

I installed asterisk now fresh on 1-12-09 I checked both i don't have an
/var/www/html/admin/bounce_oampp.sh
and on my amportal.conf the AMPWEBADDRESS= is blank, and still get the problem is it a bug?

fskrotzki
fskrotzki's picture
more details please...

more details please... Which version of asterisk and FreePBX? Last I checked the FOP does not work with any version of asterisk 1.6 yet.

pctouch
pctouch's picture
2.5.1.1

I just installed a week ago and installed all modules

fskrotzki
fskrotzki's picture
That is only half of the

That is only half of the information needed. The version of asterisk you are attempting to use?

pctouch
pctouch's picture
1.4.22

my asterisk version is the 1.4.22

fskrotzki
fskrotzki's picture
Well the FOP should

Well the FOP should work.

Now it comes down to more questions and you providing answers.

Is your system build from a distro? If so who's? If not it's hand built, so what OS, who's directions did you use (link please), what did you deviate from in the directions and why.

fyi: my bounce script is at /var/lib/asterisk/bin/bounce_op.sh

pctouch
pctouch's picture
it is the asterisk now

it is the asterisk now bistro that comes with centos 5.2, the I just downloaded it 2 weeks ago and burned the iso image and installed for testing.Also I installed all freepbx moduels available

fskrotzki
fskrotzki's picture
So that you know asterisknow

So that you know asterisknow is in Beta but it has been pretty stable, have you checked the AsteriskNow bug repoting system for this issue to see if they know about it already, and/or posted a fix for it? If not please report it to them as they might have a minor install issue.

pctouch
pctouch's picture
Bug reported

Thanks for the newa, I did check

wattsie
wattsie's picture
Interesting

Hi,
[deleted]
Cheers.

I have posted this as a bug....

Cheers.

fskrotzki
fskrotzki's picture
Please post this as a bug in

Please post this as a bug in the AsteriskNow bug tracker.

jk-la
jk-la's picture
yo solucione el problema

yo solucione el problema utilizando el comando

amportal restart

luego funciono todo...

peterg
peterg's picture
asterisknow, FOP unalbe to load message

Look like it is a typo "RUNFOP" in the configuration file
/var/www/html/admin/functions.inc.php

Error is in this line
if ($amp_conf['FOPRUN'] && !$amp_conf['FOPDISABLE']) {

the line I think should me,
if ($amp_conf['RUNFOP'] && !$amp_conf['FOPDISABLE']) {

Thats what fixed it for me.

fgendorf
fgendorf's picture
Fix that problem

Hello, I discovered that this problem in asteriskNow is becouse username from httpd is não asterisk.
To fix change User to asterisk in httpd.conf.

[]s

danielbo
danielbo's picture
is this still working for you?

I am new to this and trying real hard to learn. I went into asterisk and typed in the /var/www/html/admin/funcitions.inc.php and got a error message saying that permission denied. What did I do wrong?

pquiring
pquiring's picture
apache to asterisk and file ownership

Changing apache to run as asterisk fixed all my problems.
But there is a side effect. You might not be able to upgrade modules since file ownership is all mixed up (some apache some asterisk).
To fix that do this:
After you change apache to run as asterisk (edit /etc/httpd/conf/httpd.conf and change User/Group to asterisk then run 'service httpd restart') you should also run these commands (as root):
cd /var/www/html
chown -R asterisk:asterisk *
And everything should work.

kanesworld
kanesworld's picture
Honestly i tried all these comments and got no where.....

Can anyone give a real explation what the panel is for and why its not working and how to fix it. It seems to be a common installation problem.

Thanks You

If I figure it out bofore i see a post i will post my results...

Kane's World

SkykingOH
SkykingOH's picture
Since FOP1 is end of life

Since FOP1 is end of life and of little use (you can still go to asternic.org and see what it does) I would simply suggest installing the new FOP2. It works great.

mustardman
mustardman's picture
FOP2 has a 15 object limit

FOP2 has a 15 object limit then you have to pay. Also it's a bit of a pain to install and imho doesn't work as good as v1. So your advice is useless as usual.

SkykingOH
SkykingOH's picture
Mustardman appears to spend

Mustardman appears to spend his life following my posts to spread his vitriol.

Indeed it is a paid app, it may be difficult for him to install however it takes 3 steps and is well documented at www.fop2.com

Nicolas has done a wonderful job with the new version and it is very inexpensive. He is also very responsive to help requests.

I strongly suggest that anyone interested in FOP2 not pay any attention to mustardman's post.

mustardman
mustardman's picture
Just 3 steps? Please explain

Just 3 steps? Please explain as I'm not so good with basic math.
http://www.fop2.com/documentation-installation-from-tarball.php

He has simplified it a lot than what it was last time I looked at it about a year ago though. The limit and pay requirement is a dealbreaker for most of my customers. I'm just the messenger. But as usual Skyking is not interested knowing any of that. To him everything is a nail and the solution is always a hammer.

SkykingOH
SkykingOH's picture
#> tar zxvf

#> tar zxvf fop2-2.24-centos5-i386.tgz
Change to the extracted FOP2 directory:

#> cd fop2
For the sake of simplicity, included in the tarball there is a Makefile that can install the files for you, just type:

#> make install

Three steps, sorry one more to integrate with FreePBX dial plan.

alan_mousty
alan_mousty's picture
This thread was almost a

This thread was almost a year old.

I just installed FOP2 on 2 customer boxes. It is very easy. The FreePBX module makes it a snap to configure.

Nicolas has to make a living. I don't think $40.00 USD is to much to pay for a nice easy to use Operator Panel. Nicolas provides timely support.

If you want to stick with the original FOP that is your prerogative. FOP is not dead but it does not look like it is getting much maintenance.

Here is what Nicolas has to say about FOP and FOP2.

http://www.fop2.com/forum/viewtopic.php?f=2&t=2

SkykingOH
SkykingOH's picture
Yes, I can't believe that

Yes, I can't believe that someone would dig out a 1 year old thread just to post something negative.

mustardman
mustardman's picture
As usual, you are not

As usual, you are not interested in the context of why I would "dig out a 1 year old thread" and you absolutely refuse to ever answer anyones questions. To you every problem is a nail and every solution is a hammer.

Maybe if you spent more time looking for solutions to all the bug reports I am filing that are going unanswered (like my latest one) rather than constantly trying to prove to people that you are as smart as you think you are, then perhaps you will get a clue.

SkykingOH
SkykingOH's picture
I see a bunch of feature

I see a bunch of feature requests and one FOP1 fix. FOP1 is not supported anymore, that needs to be cleaned up.

Remember I am not a developer, not sure how many times I have to tell you that.

As far as your users, you have repeatedly been told to articulate your application, I am sure you will get more input than you could ever want for the community.

Also when I am offering options I think of the greater good. Most people can afford $50.00.

rfarchoukh
rfarchoukh's picture
Could not reload the FOP operator panel server using killall -HU

i have just upgrade my freepbx from 2.9 to 2.10 and i get the below error.
Could not reload the FOP operator panel server using killall -HUP op_server.pl. Configuration changes may not be reflected in the panel display. If the FOP module was just installed you may have to retart Asterisk with the "amportal restart" command for the FOP server to run.
system
asterix 1.8
ubuntu 3.5

kindly advise

ncforcha
ncforcha's picture
Could not reload the FOP operator

I tried all the methods above and none of them worked. What I did to get this working was to uninstall it, reboot server and install it again. The good thing is that, your license key stays even after you uninstall fop2. The downside is that, you will have to configure its permissions again.
Before doing this, I have restarted the service with "service fop2 restart"
I also ftp into my box and made some config changes to the bounce_op.sh script to no avail.
Because I was in a hurry I didn't have time to further troubleshoot the issue. I will log try to replicate the issue on another box, and then solution it and post the steps.

3CX Certified VoIP Engineer, Security+ MCP, MCSA, ITIL v3.0, Win7 Forensic