My phone (softphone wont register on freepbx 2.5.1.0) wont register

4 posts / 0 new
Last post
donegalguy2
donegalguy2's picture
My phone (softphone wont register on freepbx 2.5.1.0) wont register

Hi Guys

I have been reading the forums and have found numerous similiar issues but have tried them all and alas have had no joy in getting this too work. I have decided to outline my problem exactly so that if anyone has had the same issue I would really appreciate your input.

Ok so I installed asterisknow which has freepbx 2.5.1.0 Asterisk (Ver. 1.4.24).
It has been assigned the internal IP address of 10.0.0.84 by the dhcp server. The dns is working as I can ping google.com from the putty interface. I can also ping the asterisk server from the pc I have set the softphone on which has an ip address of 10.0.0.189 with the same subnet mask 255.0.0.0 . I have disabled the firewall on the pc I am using the softphone on so it wont interfere with what I am trying to do.

I have created an extension with the following information:
EDIT Extension -THIS IS THE HEADING
Display Name: RICKIE
CID Num Alias
SIP Alias: 2000

EXTENSION OPTIONS -
Outbound CID - 2000
The rest left default

Assigned DID/CID - Left Default

DEVICE OPTIONS
This device uses sip technology.

secret: 2000cr
dtmfmode: rfc2833
canreinvite no
context from-internal
host dynamic
type friend
nat yes
port 5060
qualify yes
callgroup
pickupgroup
disallow
allow
dial SIP/2000
accountcode
mailbox 2000@device

so that is my extension on freepbx setup. I have changed these settings alot and have checked it out changing nat to No etc etc. i dont believe that it is an extension problem anyway as I am not getting an authentication problem even when I purposely put in the incorrect credentials but I will get to that now when I get on about my softphone.

Ok I mentioned previously that I had a softphone which is the standard x-lite free phone for testing. I have set the phone up as follows again following the majority of recommendations.

Display Name : Rickie (and also used the extension 2000)
Username: 2000
password: 2000cr
authorization name: 2000
Domain: 10.0.0.84

enable: register with domain tick box
check domain on send outbound via.

Initially I thought this would work but when I try and register the phone I always get: "Registration error: 408 - request timeout" It doesnt matter what credentials I put in always the same error.

I couldnt figure out what was wrong but was advised to change the sip_nat.conf and I added the following:
localnet= 10.0.0.0/255.0.0.0

I am not using it externally from outside the network so havent added the:
externhost
nat=yes
externrefresh=10

Not sure if this makes sense?

I have run asterisk -vrr when I try and connect and I cant see any attempts to connect so I am stumped I just dont know why.

Any help would be greatly beneficial as i am pulling my hair out and as I am quite new to this i realise I have probably left crucial information out so if you can drop me a line I will supply this info.

Cheers

Rickie

blanchae
blanchae's picture
nat=no

If your softphone and Asterisk server are on the same network than nat=no. You need nat=yes if the softphone is on the other side of a firewall.

I have had some problems when the display name doesn't match the extension. So now I just make them both the same.

Eugene Blanchard

Cliffster
Cliffster's picture
I think that you may need to put the IP address in manually

I found a note (a long time ago) that said "If you are using PiaF, it is highly recommended that you use Webmin to change the IP address to Static(See Webmin for PiaF to run webmin).

However if you use Netconfig, you may have to run Netconfig again after the first time and after rebooting your PC. To change Asterisk IP address from DHCP to Static. At the command prompt enter: netconfig

ampersandhitech
ampersandhitech's picture
Softpone wont register with FreePBX

I have a asterisknow server running on a VirtualBox, It has its ethernet bridged to the host System so i can ping other systems on the network and it also can be pinged by other system , so i can confirm that there is connectivity but i was unable to Softphone 3cx to register Freepbx server, same with X-lite all the systems on the Network are in the same subnet.