time in freebpx is 1 hour more than in Elastix

9 posts / 0 new
Last post
coryjsanders
coryjsanders's picture
time in freebpx is 1 hour more than in Elastix

HOw do I synch up the two times. when I type date at my prompt the time is 1 hour behind that which displays in freepbx. Thanks.

w5waf
w5waf's picture
You probably don't have the

You probably don't have the time zone set correctly for the box that is off. Google "linux set time zone" for more info.

Bill

Bill/W5WAF
IT Specialist
City of Vicksburg, MS

coryjsanders
coryjsanders's picture
time in freepbx different than elastix

Thanks, Bill. I'm not at my box this weekend, and I don't have remote SSH. I know how to set the time at the prompt, have seen this on Google before. That time is correct. I think the problem must be in a freepbx file. Probably freepbx is not set to Arizona time, which does not change. If I set the date line to the freepbx time I'll be off an hour. Need to modify freepbx. Is there a .conf or .cfg file or something where I can do this so linux and freepbx agree? Thanks.

Linux newbie, but getting better...

SkykingOH
SkykingOH's picture
FreePBX does not have a time

FreePBX does not have a time offset, however PHP does.

Listen to Bill and set your time zone correctly.

Don't set it at the shell prompt.

You also want to make sure ntp is running with at least a few configured peers.

coryjsanders
coryjsanders's picture
FreePBX does not have time

Thanks. This is helpful. Trying to get the network admin to give me port 22 access for remote access. Will post back on success.

Linux newbie, but getting better...

rickb
rickb's picture
We seem to be having a time

We seem to be having a time issue in 2.7. We have two machine that are running the same version (2.7)and we are in Arizona. The clock on the system is the corect time zone and time but when you go into the time conditions the clock on the web page is 1 hour ahead, so with this the time conditions are not working at the correct time.

coryjsanders
coryjsanders's picture
time issue

I never got to the bottom of this. I think my time conditions work, though.

Linux newbie, but getting better...

w5waf
w5waf's picture
Make sure all of your time

Make sure all of your time zone settings on the linux server are ok.

BF

Bill/W5WAF
IT Specialist
City of Vicksburg, MS

w5waf
w5waf's picture
NO DST IN ARIZONA

Just thought of something. Arizona is the only state in the CONUS that does not observe DST. Check to see if the DST flags are correct.

BF

Bill/W5WAF
IT Specialist
City of Vicksburg, MS