Outbound route uses wrong trunk

12 posts / 0 new
Last post
eg0e
eg0e's picture
Outbound route uses wrong trunk

I've got 2 trunks, one is only for DID (didforsale.com), I cannot use it for outbound. The second I use for my outbound termination (flowroute.com).

I set up my outbound route trunk sequence, 0 is flowroute, didforsale isn't listed at all.

When I attempt to make an outbound call, I get "all circuits are busy now" and my asterisk CLI shows this...
Executing [s@macro-dialout-trunk:22] Dial("SIP/701-00000008", "SIP/didforsale_did/1612xxxxxxx,300,") in new stack

I don't understand why it's doing anything at all with that trunk!

I'm sure you will need more information, but I'm pretty new to the whole VOIP thing, can anyone get me on the right track?

eg0e
eg0e's picture
24 hour bump. Sorry if this

24 hour bump. Sorry if this is considered improper.

SkykingOH
SkykingOH's picture
Need system information and

Need system information and versions please. Especially FreePBX version and how it was installed.

Logs would be helpful, a database dump from outbound would be good too.

eg0e
eg0e's picture
Info

Thanks for the response.
Installed via PBXinaFlash version 2.0.6.2
FreePBX version 2.10.1.4
asterisk version 1.8.13.0
Running on CentOS 6.2

Here is my log from /var/log/asterisk/full
http://pastebin.com/cArL8c90

Can you tell me how to do the database dump?

SkykingOH
SkykingOH's picture
The custom SIP flowroute is

The custom SIP flowroute is in the wrong context so you are essentially routing the call back you yourseld

how to dump:

mysql
use asterisk;
select * from outbound_route_patterns_patterns;
select * from outbound_route_sequence;
select * from outbound_route_trunks;

Also peer and user details from trunks.

eg0e
eg0e's picture
"The custom SIP flowroute is

"The custom SIP flowroute is in the wrong context so you are essentially routing the call back you yourself"

Can you elaborate on this? How do I change the context?

eg0e
eg0e's picture
Once again, thank you for

Once again, thank you for your response.
I'm not sure what you mean by flowroute being in the wrong context... should it not be in from-trunk?

I'm not sure how to paste the results of the SQL queries in a non-eye shattering way, so I'll just type them in; hopefully this is what you are looking for.

Outbound route patterns under match_pattern_pass.
All have route_id of 7, prefix, cid and prepend all blank:
1NXXNXXXXXX
NXXNXXXXXX
NXXXXXX

Outbound route sequence:
route_id 7 seq 0

outbound route trunks:
Route_id 7, trunk_id 2, seq 0

Flowroute peer details:
type=friend
secret=somesecret
username=someuser
host=sip.flowroute.com
dtmfmode=rfc2833
context=from-trunk
canreinvite=no
allow=ulaw&g729
insecure=port,invite
fromdomain=sip.flowroute.com

User details blank

register string:
user:secret@sip.flowroute.com

didforsale peer details:
type=peer
nat=no
host=209.216.2.211&209.216.15.70
dtmfmode=rfc2833
disallow=all
context=from-trunk
allow=ulaw&alaw

user details blank

register string blank

eg0e
eg0e's picture
Can I provide any more

Can I provide any more information?
I'd really like to get this resolved.
If someone knows of a good paid support, I am willing to go that route.

w5waf
w5waf's picture
Paid Support

Go to the top of this page under store.

BF

Bill/W5WAF
IT Specialist
City of Vicksburg, MS

eg0e
eg0e's picture
whew.... $150.. that's a

whew.... $150.. that's a little more than I was hoping for since I can't think this will take nearly an hour once someone looks into it. I'll have to keep googling I guess.

eg0e
eg0e's picture
So I found the issue. there

So I found the issue. there was an errant line in my extensions_custom.conf which was forcing extension 701 to use trunk 1. I got rid of the line and everything now works as it should.

SkykingOH
SkykingOH's picture
eg0e, that's why I saw it

eg0e, that's why I saw it going to the wrong trunk.

Your log didn't reconcile to your trunks settings so I had nothing else to off er you.