FreePBX® to support Asterisk 1.4

So what’s going on with Asterisk 1.4 and the plans to “End of Life” version 1.2? If you have not already heard, it was decided at the recent Asterisk Developers Conference: “One decision that we took was to stop maintaining 1.2 as a current release from August 1st 2007. At that date, we will move 1.2 of Asterisk, Asterisk-addons, libpri and zaptel to security maintenance status. 1.4 will at that point be the recommended release.”

What does this mean for FreePBX® since it only supports Asterisk 1.2 today?

Before addressing this question, please rest assured that Asterisk 1.2 is alive, well and the most stable release currently available. Many people only upgrade because of security patches supplied in new releases and these security fixes will continue. So no one should be alarmed by this announcement. Asterisk 1.2 will be strong and running for many months (and years) to come.

So what about FreePBX® and Asterisk 1.4?

As a community leader we will respect Digium’s desire to get more users onto Asterisk 1.4 and will do our part to support their efforts. We’ve been planning to enable Asterisk 1.4 on our FreePBX® 2.3, which is the current development branch. FreePBX® 2.3 is currently very stable on Asterisk 1.2.

What this means

We will branch the development trunk into its proper 2.3 release candidate shortly, and start the formal beta program. If you run the FreePBX® 2.3 beta on Asterisk 1.2, you should have a very stable system. If you choose to start “kicking the tires” with Asterisk 1.4, you should consider this FreePBX® release alpha quality. We will address bugs as they surface and quickly find out just how much work there is to do.

Things are going to be heating up for the team with this plan; we’ll try to get you more details soon. In the mean time – moral support to help accelerate the effort is always appreciated, especially the kind that you can show with that nifty donate button off on the left.

-philippel (on behalf of the team)

Leave a Reply