Whoops. Enum Lookups broken in 2.2.0

For anyone using Enum trunks in 2.2.0, they would be unhappy to find that it’s giving them a wierd authentication error. Whoops. I’ve got a check back-to-front in the extensions.conf file. It’s a really easy fix, edit line 428 of /etc/asterisk/extensions.conf and put a “!” before the = sign. The line should read (when fixed):

exten => s,1,GotoIf($["${ARG3}" != ""]?PASSWD:NOPASSWD); arg3 is pattern password

Note that I’ve put the ! in bold so you can see where it’s meant to be.

If everyone can get busy and find some more bugs and report them, I can roll up a 2.2.1 release shortly!

Leave a Reply