utils.c broken pipe error - Asterisk or Application error?

6 posts / 0 new
Last post
mag
mag's picture
utils.c broken pipe error - Asterisk or Application error?

Hi,

I'm currently running FreePBX 2.5.1 with Asterisk 1.4.23.1.

I am seeing the following error in the Asterisk logs

[2009-03-17 03:30:03] VERBOSE[4431] logger.c: == Parsing '/etc/asterisk/manager_custom.conf': [2009-03-17 03:30
:03] VERBOSE[4431] logger.c: Found
[2009-03-17 03:30:03] VERBOSE[4431] logger.c: == Manager 'phpagi' logged on from 127.0.0.1
[2009-03-17 03:30:03] ERROR[4431] utils.c: write() returned error: Broken pipe
[2009-03-17 03:30:03] VERBOSE[4431] logger.c: == Manager 'phpagi' logged off from 127.0.0.1

I believe it may be related to this bug and the AMI, although I can't be sure as I don't know what FreePBX is doing at the time
http://bugs.digium.com/view.php?id=14379

This claims that the issue is on the client side, not Asterisk.

Is this a concern because some files are not being written - " if you make several changes to a the same file using updateconfig, after the first 'broken pipe' changes are not written"?

I am not seeing this issue with Asterisk 1.4.22

Thanks

mag
mag's picture
Just upgraded to 1.4.24.1

Just upgraded to 1.4.24.1 and I am still seeing this error -

It appears to be happening every 5 minutes.
This is on a fresh install with no phones or anything else connected.

No-one else seeing this error at all?

MaG

danswartz
danswartz's picture
i'm confused

The issue in digium bugtracker refers to the 1.6 code branch, not 1.4.

mag
mag's picture
Problem Solved

I managed to find where the problem lies and it is not with FreePBX!

I had installed munin and the Asterisk plugins - a few of these plugins were causing the error.

M

MaG

Hat
Hat's picture
How?

Mag,

I have the same issue. I too, have munin and Asterisk 1.4.24.1 installed. Can you please elaborate as to what you did to resolve your issue?

Thanks,
Tom

mag
mag's picture
I had to disable the

I had to disable the asterisk munin scripts in order to remove the error - not all of them though. I just removed the soft links from the /etc/munin/plugins directory.

I think the scripts need to be updated for Asterisk 1.4, but I don't have the time at the moment to look into them. If I ever do get round to it, I'll post the new ones somewhere (unless someone else has already done so?)

M

MaG